Re: [PATCH v3 0/6] arm64: dts: qcom: clean up PCI function nodes

From: Bjorn Andersson

Date: Thu Sep 03 2026 - 13:58:33 EST



On Wed, 02 Sep 2026 16:43:14 -0500, Alex Elder wrote:
> While working on upstream support for the Toshiba TC9564 SoC I
> discovered that the way its PCIe endpoint function nodes are
> defined in devicetree files is incorrect. Two issues have been
> pointed out during the course of review:
> - Only PCI bridge device nodes should contain this property:
> device_type = "pci";
> - Only bridge device nodes should be named "pcie@" (or "pci@")
>
> [...]

Applied, thanks!

[1/6] arm64: dts: qcom: qcs6490-rb3gen2: clean up PCI function nodes
commit: df4107fc729e3bffce27fe0ed06fc6a64dd675cd
[2/6] arm64: dts: qcom: qcs6490-rb3gen2-industrial-mezzanine: clean up PCI function nodes
commit: aaedd4ea312d6fd70dfc5cf430edf5106c5b3382
[3/6] arm64: dts: qcom: lemans-evk-ifp-mezzanine: clean up PCI function nodes
commit: ca3027cfe8c7ef612910d2f04e58d75ec8a9b427
[4/6] arm64: dts: qcom: monaco-evk-ifp-mezzanine: clean up PCI function nodes
commit: 0f8cbe572057b0ef98c651fbd6da1877983c7165
[5/6] arm64: dts: qcom: qcs6490-thundercomm-minipc-g1iot: clean up PCI function nodes
commit: 55580d234cec123e9b2964cab30fbfad10774b26
[6/6] arm64: dts: qcom: qcs8550-rb5gen2: clean up PCI function nodes
commit: 3f7d46aaf5565471f65b2e21fbb649cedc55e6b8

Best regards,
--
Bjorn Andersson <andersson@xxxxxxxxxx>