[PATCH v2 5/8] mm/swapfile: use folio_page_swap_entry()

From: Tal Zussman

Date: Tue Sep 08 2026 - 12:42:44 EST


folio_dup_swap() and folio_put_swap() open-code the swap entry
computation from folio->swap and folio_page_idx(). Use
folio_page_swap_entry() instead.

No functional change.

Signed-off-by: Tal Zussman <tz2294@xxxxxxxxxxxx>
---
mm/swapfile.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/mm/swapfile.c b/mm/swapfile.c
index 869a918b18e8..0a3a3b2218c7 100644
--- a/mm/swapfile.c
+++ b/mm/swapfile.c
@@ -1822,7 +1822,7 @@ int folio_dup_swap(struct folio *folio, struct page *page)
VM_WARN_ON_FOLIO(!folio_test_swapcache(folio), folio);

if (page) {
- entry.val += folio_page_idx(folio, page);
+ entry = folio_page_swap_entry(folio, page);
nr_pages = 1;
}

@@ -1849,7 +1849,7 @@ void folio_put_swap(struct folio *folio, struct page *page)
VM_WARN_ON_FOLIO(!folio_test_swapcache(folio), folio);

if (page) {
- entry.val += folio_page_idx(folio, page);
+ entry = folio_page_swap_entry(folio, page);
nr_pages = 1;
}


--
2.39.5