Re: [PATCH net-next v3 3/4] NTB: ntb_transport: Add per-payload client metadata
From: Jakub Kicinski
Date: Thu Sep 10 2026 - 20:24:34 EST
On Fri, 4 Sep 2026 14:21:33 +0900 Koichiro Den wrote:
> +/* Reserve the low byte for transport flags. */
> +#define DESC_META_SHIFT 8
> +#define DESC_META_MASK (~0U << DESC_META_SHIFT)
IMHO the code would be more readable if you defined this with
one GENMASK and then used FILED_GET() / _PREP() / _MAX() on it