Re: [PATCH net-next v3 3/4] NTB: ntb_transport: Add per-payload client metadata

From: Koichiro Den

Date: Fri Sep 11 2026 - 04:02:09 EST


On Thu, Sep 10, 2026 at 05:18:56PM -0700, Jakub Kicinski wrote:
> On Fri, 4 Sep 2026 14:21:33 +0900 Koichiro Den wrote:
> > +/* Reserve the low byte for transport flags. */
> > +#define DESC_META_SHIFT 8
> > +#define DESC_META_MASK (~0U << DESC_META_SHIFT)
>
> IMHO the code would be more readable if you defined this with
> one GENMASK and then used FILED_GET() / _PREP() / _MAX() on it

Will do, thanks for the review!

Best regards,
Koichiro