Re: [PATCH 1/2] include/linux: Defining bool, false and true
From: Jeff Garzik
Date: Tue Aug 01 2006 - 17:21:56 EST
H. Peter Anvin wrote:
This patch defines:
* a generic boolean-type, named "bool"
* aliases to 0 and 1, named "false" and "true"
Signed-off-by: Richard Knutsson <ricknu-0@xxxxxxxxxxxxxx>
Shouldn't this simply use _Bool?
No sane person should use "_Bool" in real code. Unnecessary StudlyCaps
and unnecessary underscore.
"bool" is far easier to type, and looks less weird.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/