How to get backtrace? modprobe -r iwlagn; modprobe iwlagn kills kernel

From: Stevie Trujillo
Date: Wed May 18 2011 - 10:37:54 EST


I'm having some problem getting a backtrace. When I do "modprobe -r iwlagn;
modprobe iwlagn" ( with Intel-1030N) the kernel crashes (sometimes I
need to try 2 or 3 times, and sometimes the modprobe -r is the one that
This spams my monitor with several oops/panics before it finally dies. I can
only see bottom of the last one, which probably isn't very meaningful.
I tried loading netconsole, but I only get one or two lines before it stops
I then tried kexec+crashkernel, but I only managed to get a backtrace for the
last panic (which I think is just a result of memory corruption or something).
Finally I tried compiling ramoops into my kernel, but it didn't want to load
because of "No such device".

Stevie Trujillo
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at