Re: [PATCH] staging: brcm80211: brcmfmac: Add and use dhd_dbg

From: Henry Ptasinski
Date: Wed May 18 2011 - 18:46:23 EST

On 05/18/2011 11:23 AM, Joe Perches wrote:
All uses of DHD_<TYPE> macros are for debugging only.

Change the multiple uses of DHD_<TYPE>((...)) to dhd_dbg(TYPE, ...)
for a more consistent style.

I generally like this approach, but in brcmsmac we've been switching to wiphy_err() and related instead. Any strong argument for one over the other?

- DHD_TRACE(("%s: Enter\n", __func__));
+ dhd_dbg(TRACE, "%s: Enter\n", __func__);

I'd propose moving __func__ into the macro definition itself, which would help ensure consistency (and shorten all the debug lines a bit).

Also, perhaps rename to "brcm_dbg()", "bcm_dbg()" or something like that and move it into include/bcmutils.h, so brcmsmac can use it as well.

- Henry

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at