Re: vanilla 2.6.0-test11 and CS4236 card

From: Joseph Pingenot
Date: Wed Dec 03 2003 - 09:11:37 EST

>From Takashi Iwai on Wednesday, 03 December, 2003:
>At Tue, 2 Dec 2003 21:17:51 -0600,
>Joseph Pingenot wrote:
>> -------------
>> Both times (with your patch and with isapnp), I had the following problems:
>> a) xmms wouldn't talk straight to the card even after selecting the alsa
>> output plugin
>what was the error exactly?

Standard thing when it can't talk to the sound card:

"Please check that:
1. You have the correct output plugin selected
2. No other programs is(sic) blocking the soundcard
3. Your soundcard is configured properly


FWIW, ALSA for the cs4281 chip on my home box works 100%, and xmms can talk
to it without problem. These are different distros (gentoo@home, debian@work)
so it may also be a problem in Debian, but I don't think so.

>> b) I started esd (the alsa version) and then told xmms to talk to esd.
>> It worked out well for a couple of seconds, but then it crashed
>> (both with your patch and with the manually activated (isapnp) one)
>> It crashed HARD.
>oh, that's bad.

Ja. I'm gonna have to sort it out whenever I can get my homework done.
Either this afternoon or tomorrow. Just gotta copy some files over by
floppy (e.g. route) and then tar them over from another machine.

>> It crashed so hard that it wiped out some files, like apt, I presume
>> when it was cleaning "orphans" in /; the net result is that my
>> box is semi-hosed, since things like tr and apt-get and route
>> are now full of '\0' characters instead of their actual contents.
>> Sound played for about a second, then the machine hung hard (I don't think
>> that the Magic SysRq keys even did anything), and the last couple of
>> tenths of a second of sound just repeated over and over and over until
>> I hit reset. I don't have an oops; it was highly hosed.
>> When I can pull my system back together, I can try again. Please help
>> me find this new bug, so that the cs4236 driver is safe for other
>> Dell P410 users! :)
>i'm puzzled because cs4236's pcm code is basically identical with
>cs4231, and cs4232 seems working (at least the last time i tested).
>anyway, please show the kernel config and check any other apps do
>similar oops / crash.

Hmm. I dunno. The only odd thing atm is that the nvidia driver was loaded
and had reported a couple of bugs. When the machine's up next time,
I'll try it sans nvidia and see what we get. I don't suspect that's the
problem, as everything but sound worked 100%, but we'll see.

Other than my diagnostic print statements or your pnp patch, everything
at runtime was vanilla (except nvidia of course)


"Asked by CollabNet CTO Brian Behlendorf whether Microsoft will enforce its
patents against open source projects, Mundie replied, 'Yes, absolutely.'
An audience member pointed out that many open source projects aren't
funded and so can't afford legal representation to rival Microsoft's. 'Oh
well,' said Mundie. 'Get your money, and let's go to court.'
Microsoft's patents only defensive?
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at