Re: [Update][RFC][PATCH] PM / Runtime: Add sysfs switch for disabling device run-time PM

From: Rafael J. Wysocki
Date: Wed Jan 20 2010 - 16:09:14 EST

On Wednesday 20 January 2010, Alan Stern wrote:
> On Tue, 19 Jan 2010, Rafael J. Wysocki wrote:
> > > Why change the name from "level" to "runtime"?
> >
> > Because it wouldn't be really obvious what "level" applied to. For example,
> > some people might expect the values of "level" to correspond to PCI power
> > states for PCI devices and so on, so it might turn out to be confusing.
> But is the name "runtime" any clearer? Especially to people who have
> never come across the phrase "runtime power management"?
> Does anybody have a suggestion for a better attribute name?

Apparently not, but I can try. ;-)

* status

* power (power/power looks weird, but the values would make sense)

* control

No more ideas for now.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at