Re: staging: ks7010: Rename jump labels

From: Jean Delvare
Date: Mon Jul 25 2016 - 17:02:44 EST

Hello Markus,

On lun., 2016-07-25 at 18:19 +0200, SF Markus Elfring wrote:
> >> Would you like to support the renaming of a label like "error_out1"
> >> (in the function "ks7010_upload_firmware" for example)?
> >
> > They should be renamed too. Anything using numbers instead of explicit
> Interesting â
> > Anything using numbers instead of explicit labels should be updated.
> Would you dare to search for corresponding update candidates explicitly
> by special semantic patch scripts?

No. You started it all, and I do not have more time to devote to it. I
do not find it all particularly interesting, to be honest. I have a lot
of other things to work on, of much greater interest (to me.)

> > I included the reasons in the patch I just sent,
> > hopefully the documentation is clearer now.
> I am curious on how feedback will evolve for your suggestion
> "CodingStyle: Clarify and complete chapter 7".
> How do you think about to show a shorter label like "free_bar"
> (instead of "err_free_bar") as an example?

Up to whoever writes and maintains the code. As most things should be in
the absence of a compelling reason to normalize.

> >> "Source code review around jump label usage"?
> >>
> >>
> >
> > Personally I see no value in such statistics.
> Do they indicate any code smells eventually?

I have no idea what you mean, sorry.

> > Either labels are wrong (either wrong indentation or wrong name)
> > and should be fixed, or they are correct and you should not touch them.
> Do you find such changes worthwhile (without touching also any surrounding
> source code)?

You keep asking more and more from me. May I remind you this is your
"project" in the first place, not mine? If you have no idea what should
be done, or even whether anything should be done, then just move on to
something else. I have already expressed all my views on this topic and
am not willing to say anything more about it.

Jean Delvare
SUSE L3 Support