Re: [PATCH 6/7] sched: Rename root_domain->overload to should_idle_balance

From: Peter Zijlstra
Date: Fri Feb 16 2018 - 04:49:32 EST


On Fri, Feb 16, 2018 at 10:14:02AM +0100, Juri Lelli wrote:
> > diff --git a/kernel/sched/sched.h b/kernel/sched/sched.h
> > index 7d324b706e67..4215438667e5 100644
> > --- a/kernel/sched/sched.h
> > +++ b/kernel/sched/sched.h
> > @@ -650,8 +650,12 @@ struct root_domain {
> > cpumask_var_t span;
> > cpumask_var_t online;
> >
> > - /* Indicate more than one runnable task for any CPU */
> > - bool overload;
> > + /*
> > + * Indicate whether the idle balance can be used to solve
> > + * imbalance within the root domain.
> > + * e.g. There is more than one runnable task for any CPU
> > + */
> > + bool should_idle_balance;
>
> Current name is however consistent with RT/DL's naming convention

Yeah, not a fan either. We've consistently used the term to mean
nr_running>1. The thing to fix there is the stupid bool, not the name.