Re: [PATCH 6/7] sched: Rename root_domain->overload to should_idle_balance

From: Juri Lelli
Date: Fri Feb 16 2018 - 04:14:11 EST


Hi,

On 15/02/18 16:20, Morten Rasmussen wrote:
> From: Valentin Schneider <valentin.schneider@xxxxxxx>
>
> The name "overload" is not very explicit, especially since it doesn't
> use any concept of "load" coming from load-tracking signals. For now it
> simply tracks if any of the CPUs in root_domain has more than one
> runnable task, and is then used to decide whether idle balance should be
> performed.
>
> As such, this commit changes that flag's name to 'should_idle_balance',
> which makes its role more explicit.
>
> cc: Ingo Molnar <mingo@xxxxxxxxxx>
> cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> Suggested-by: Patrick Bellasi <patrick.bellasi@xxxxxxx>
> Signed-off-by: Valentin Schneider <valentin.schneider@xxxxxxx>
> Signed-off-by: Morten Rasmussen <morten.rasmussen@xxxxxxx>
> ---

[...]

> diff --git a/kernel/sched/sched.h b/kernel/sched/sched.h
> index 7d324b706e67..4215438667e5 100644
> --- a/kernel/sched/sched.h
> +++ b/kernel/sched/sched.h
> @@ -650,8 +650,12 @@ struct root_domain {
> cpumask_var_t span;
> cpumask_var_t online;
>
> - /* Indicate more than one runnable task for any CPU */
> - bool overload;
> + /*
> + * Indicate whether the idle balance can be used to solve
> + * imbalance within the root domain.
> + * e.g. There is more than one runnable task for any CPU
> + */
> + bool should_idle_balance;

Current name is however consistent with RT/DL's naming convention

[...]
/*
* The bit corresponding to a CPU gets set here if such CPU has more
* than one runnable -deadline task (as it is below for RT tasks).
*/
cpumask_var_t dlo_mask;

[...]

/*
* The "RT overload" flag: it gets set if a CPU has more than
* one runnable RT task.
*/
cpumask_var_t rto_mask;

Not a big deal, though. Just wanted to point that out. :)

Best,

- Juri