Re: [PATCH 5/7] lib: rework bitmap_parse()

From: Andy Shevchenko
Date: Mon Jul 22 2019 - 09:37:34 EST


On Sun, Jul 21, 2019 at 02:27:51PM -0700, Yury Norov wrote:
> From Yury Norov <ynorov@xxxxxxxxxxx>
>
> bitmap_parse() is ineffective and full of opaque variables and opencoded
> parts. It leads to hard understanding and usage of it. This rework
> includes:
> - remove bitmap_shift_left() call from the cycle. Now it makes the
> complexity of the algorithm as O(nbits^2). In the suggested approach
> the input string is parsed in reverse direction, so no shifts needed;
> - relax requirement on a single comma and no white spaces between chunks.
> It is considered useful in scripting, and it aligns with
> bitmap_parselist();
> - split bitmap_parse() to small readable helpers;
> - make an explicit calculation of the end of input line at the
> beginning, so users of the bitmap_parse() won't bother doing this.

> Signed-off-by: Yury Norov <ynorov@xxxxxxxxxxx>
> Signed-off-by: Yury Norov <yury.norov@xxxxxxxxx>

I'm not sure this is good to have two SoB tags for one person.

> + if (hex_to_bin(*end) < 0)

Isn't it simple isxdigit() check?

> + return ERR_PTR(-EINVAL);
> +

> + for (i = 0; i < 32; i += 4) {
> + c = hex_to_bin(*end--);
> + if (c < 0)
> + return ERR_PTR(-EINVAL);
> +
> + ret |= c << i;

Dunno if it's for this series, but perhaps we would like to have something like

/* Convert hex representation of u32 value to binary format */
static inline int hex2bin32(const char *buf, u32 *result)
{
u8 value[4];
int ret;

ret = hex2bin(value, buf, sizeof(u32));
if (ret)
return ret;

*result = get_unaligned((u32 *)value);
// I guess it's aligned and thus can be done with:
// *result = be32_to_cpup((__force __be32 *)value);
// just don't like enforcing bitwise types
return 0;
}

// also can be your variant with for-loop.

At least here for now and then can be moved to the kernel.h / hexdump.c.

> +
> + if (start > end || __end_of_region(*end))
> + goto out;
> + }
> +

> + if (hex_to_bin(*end) >= 0)

Isn't it simple isxdigit() check?

> + return ERR_PTR(-EOVERFLOW);

--
With Best Regards,
Andy Shevchenko