On Sat, May 03, 2025 at 09:54:35PM +0530, Nitin Rawat wrote:
Rename qmp_ufs_disable to qmp_ufs_power_off to better represent its
functionality. Additionally, move the qmp_ufs_exit() call inside
qmp_ufs_power_off to preserve the functionality of .power_off.
There is no functional change.
Signed-off-by: Nitin Rawat <quic_nitirawa@xxxxxxxxxxx>
---
drivers/phy/qualcomm/phy-qcom-qmp-ufs.c | 30 +++++++++----------------
1 file changed, 11 insertions(+), 19 deletions(-)
diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
index 94095393148c..c501223fc5f9 100644
--- a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
+++ b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
@@ -1835,6 +1835,15 @@ static int qmp_ufs_phy_calibrate(struct phy *phy)
return 0;
}
+static int qmp_ufs_exit(struct phy *phy)
+{
+ struct qmp_ufs *qmp = phy_get_drvdata(phy);
+
+ qmp_ufs_com_exit(qmp);
Just inline it, unless you have any other plans.
+
+ return 0;
+}
+
static int qmp_ufs_power_off(struct phy *phy)
{
struct qmp_ufs *qmp = phy_get_drvdata(phy);
@@ -1851,28 +1860,11 @@ static int qmp_ufs_power_off(struct phy *phy)
qphy_clrbits(qmp->pcs, cfg->regs[QPHY_PCS_POWER_DOWN_CONTROL],
SW_PWRDN);
- return 0;
-}
-
-static int qmp_ufs_exit(struct phy *phy)
-{
- struct qmp_ufs *qmp = phy_get_drvdata(phy);
-
- qmp_ufs_com_exit(qmp);
+ qmp_ufs_exit(phy);
return 0;
}
-static int qmp_ufs_disable(struct phy *phy)
-{
- int ret;
-
- ret = qmp_ufs_power_off(phy);
- if (ret)
- return ret;
- return qmp_ufs_exit(phy);
-}
-
static int qmp_ufs_set_mode(struct phy *phy, enum phy_mode mode, int submode)
{
struct qmp_ufs *qmp = phy_get_drvdata(phy);
@@ -1921,7 +1913,7 @@ static int qmp_ufs_phy_init(struct phy *phy)
static const struct phy_ops qcom_qmp_ufs_phy_ops = {
.init = qmp_ufs_phy_init,
.power_on = qmp_ufs_power_on,
- .power_off = qmp_ufs_disable,
+ .power_off = qmp_ufs_power_off,
.calibrate = qmp_ufs_phy_calibrate,
.set_mode = qmp_ufs_set_mode,
.owner = THIS_MODULE,
--
2.48.1