Re: [PATCH 1/3] staging: rtl8723bs: rename mBratesOS to avoid CamelCase
From: Olivier Tanoh
Date: Tue Jul 28 2026 - 08:27:15 EST
On Mon, Jul 28, 2026, Greg KH wrote:
> Why are you keeping the "m" and "b" here? Does that match up with what
> is really stored in this variable?
You're right, the "m" and "b" prefixes are Hungarian notation and don't
describe the content. The variable holds the basic rates array, so
basic_rates is a clearer name. I'll send a v2.
Thanks for the review,
Olivier
Le mar. 28 juil. 2026 à 09:30, Greg KH <gregkh@xxxxxxxxxxxxxxxxxxx> a écrit :
>
> On Mon, Jul 20, 2026 at 02:45:42PM +0200, Olivier Tanoh wrote:
> > Fix checkpatch.pl warning regarding the use of CamelCase:
> > CHECK: Avoid CamelCase: <mBratesOS>
> >
> > Rename the struct member mBratesOS to comply with the
> > Linux kernel coding style.
>
> Why are you keeping the "m" and "b" here? Does that match up with what
> is really stored in this variable?
>
> thanks,
>
> greg k-h