SMP no boot in 2.1.110

Matthew G. Marsh (
Fri, 24 Jul 1998 14:59:11 -0500 (CDT)

Well - sorry to bother everyone again but I isolated the boot freeze up to
SMP. Brief info here:

2.1.110 is the kernel compiled with a rm -rf of the kernel tree every time
in between just to make sure.

w/SMP & PPro defined freezes at "Checking 'htl' instruction... "
w/SMP & 486 defined freezes at "Checking 'hlt' instruction... "
w/UP & PPro defined boots with no problem

Also tried setting my system BIOS to report MP 1.1 instead of MP 1.4 and
get the same exact error. I have not tried 107-109 yet to see if they have
the same freezeup. I have been running 106 since its release with SMP with
no problems at all.

>Well - Have been running 2.1.106 for a few weeks now no hitches. Went and
>got 2.1.110 and it compiled with only some warnings of redef's. When I go
>to boot it locks the machine solid at "Checking 'hlt' instruction..." -
>never gets to OK. No SySRQ, no response, but it does turn on the NUMLOCK
>on the keyboard.


Intel DK440LX Bios Rev 9
(2) P-II 333Mhz
IDE Boot disk & CDROM
(2) AIC-7870 channels
9G Micropolis UW
4.3G Connor narrow
Phillips CDWriter
Sony DAT

If you would like any other info or would like me to try anything let me
know. Thanks!

Matthew G. Marsh, President
Paktronix Systems, LLC
1506 North 59th Street
Omaha NE 68104
Phone: (402) 553-2288

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at