Re: [PATCH] KVM: VMX: replace "fall through" with "return true" to indicate different case

From: Joe Perches
Date: Mon Feb 17 2020 - 22:44:20 EST


On Tue, 2020-02-18 at 11:39 +0800, linmiaohe wrote:
> The second "/* fall through */" in rmode_exception() makes code harder to
> read. Replace it with "return true" to indicate they are different cases
> and also this improves the readability.
[]
> diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c
[]
> @@ -4495,7 +4495,7 @@ static bool rmode_exception(struct kvm_vcpu *vcpu, int vec)
> if (vcpu->guest_debug &
> (KVM_GUESTDBG_SINGLESTEP | KVM_GUESTDBG_USE_HW_BP))
> return false;
> - /* fall through */
> + return true;

perhaps
return !(vcpu->guest_debug & (KVM_GUESTDBG_SINGLESTEP | KVM_GUESTDBG_USE_HW_BP));