[PATCH 00/22] tty: vt: cleanup ESC sequences handling

From: Jiri Slaby (SUSE)
Date: Fri Feb 02 2024 - 01:56:22 EST


This is a promised followup of "tty: vt: cleanup and documentation" [1].

The escape sequences parser is cleaned up, so that it is easier to
follow.

Most of the patches are easier to review with '-w -b' passed to git diff
(as the code is moved to separate functions with a different level of
indentation only).

[1] https://lore.kernel.org/all/20240122110401.7289-28-jirislaby@xxxxxxxxxx/T/

Jiri Slaby (SUSE) (22):
tty: vt: make rgb_from_256() slighly more comprehensible
tty: vt: define enums for CSI+h/l codes
tty: vt: rename set_mode() to csi_hl()
tty: vt: split DEC CSI+h/l handling into csi_DEC_hl()
tty: vt: remove unneeded assignment of EPecma to vc_priv
tty: vt: move CSI+n handling along to other ECMA CSIs
tty: vt: define an enum for CSI+] codes
tty: vt: rename setterm_command() to csi_RSB()
tty: vt: put cases on separate lines
tty: vt: accept u8 in do_con_trol() and vc_setGx()
tty: vt: extract ascii handling to handle_ascii()
tty: vt: separate ESesc state handling into handle_esc()
tty: vt: move CSI DEC handling to a separate function
tty: vt: move CSI ECMA handling to a separate function
tty: vt: name, reflow and document enum vc_ctl_state
tty: vt: simplify ansi_control_string()
tty: vt: handle CSI+[ inside preexisting switch-case
tty: vt: add new helper for reseting vc parameters
tty: vt: use switch+case in the ESnonstd case
tty: vt: use switch+case in the ESgetpars case
tty: vt: use ASCII enum constants in vt_console_print()
tty: vt: decrypt magic constants in vc_is_control()

drivers/tty/vt/vt.c | 876 ++++++++++++++++++++++++++------------------
1 file changed, 514 insertions(+), 362 deletions(-)

--
2.43.0