[PATCH] ACPICA: Use swap() instead of open coding it

From: Jiapeng Chong
Date: Fri Feb 02 2024 - 03:20:55 EST


Swap is a function interface that provides exchange function. To avoid
code duplication, we can use swap function.

/drivers/acpi/acpica/nsrepair2.c:896:33-34: WARNING opportunity for swap().

Reported-by: Abaci Robot <abaci@xxxxxxxxxxxxxxxxx>
Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=8168
Signed-off-by: Jiapeng Chong <jiapeng.chong@xxxxxxxxxxxxxxxxx>
---
drivers/acpi/acpica/nsrepair2.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/acpi/acpica/nsrepair2.c b/drivers/acpi/acpica/nsrepair2.c
index 1bb7b71f07f1..ccd89a82a4e6 100644
--- a/drivers/acpi/acpica/nsrepair2.c
+++ b/drivers/acpi/acpica/nsrepair2.c
@@ -875,7 +875,6 @@ acpi_ns_sort_list(union acpi_operand_object **elements,
{
union acpi_operand_object *obj_desc1;
union acpi_operand_object *obj_desc2;
- union acpi_operand_object *temp_obj;
u32 i;
u32 j;

@@ -892,9 +891,7 @@ acpi_ns_sort_list(union acpi_operand_object **elements,
|| ((sort_direction == ACPI_SORT_DESCENDING)
&& (obj_desc1->integer.value <
obj_desc2->integer.value))) {
- temp_obj = elements[j - 1];
- elements[j - 1] = elements[j];
- elements[j] = temp_obj;
+ swap(elements[j], elements[j - 1]);
}
}
}
--
2.20.1.7.g153144c