Re: [PATCH v1 02/18] thermal: Add new structures and thermal_zone_device_register()

From: Dan Carpenter
Date: Fri Feb 02 2024 - 03:48:54 EST


On Thu, Feb 01, 2024 at 08:24:15PM +0100, Rafael J. Wysocki wrote:
> On Tue, Jan 30, 2024 at 12:13 PM AngeloGioacchino Del Regno
> > diff --git a/include/linux/thermal.h b/include/linux/thermal.h
> > index 65d8f92a9a0d..7a540b746703 100644
> > --- a/include/linux/thermal.h
> > +++ b/include/linux/thermal.h
> > @@ -149,7 +149,8 @@ struct thermal_cooling_device {
> > passive trip point.
> > * @need_update: if equals 1, thermal_zone_device_update needs to be invoked.
> > * @ops: operations this &thermal_zone_device supports
> > - * @tzp: thermal zone parameters
> > + * @tzp: Thermal zone parameters
> > + * @tgp: Thermal zone governor parameters
> > * @governor: pointer to the governor for this thermal zone
> > * @governor_data: private pointer for governor data
> > * @thermal_instances: list of &struct thermal_instance of this thermal zone
> > @@ -184,7 +185,8 @@ struct thermal_zone_device {
> > int prev_high_trip;
> > atomic_t need_update;
> > struct thermal_zone_device_ops *ops;
> > - struct thermal_zone_params *tzp;
> > + struct thermal_zone_platform_params *tzp;
> > + struct thermal_governor_params *tgp;
>
> I agree with doing a split here, but I'm not sure about moving items
> from the arg list to struct thermal_zone_platform_params (as mentioned
> above).
>
> Also the naming is quite inconsistent. IMO it would be better to call
> the first pointer "tzpp", rename struct thermal_governor_params to
> struct thermal_zone_governor_params and call the second pointer
> "tzgp".
>

The names "tzgp" and "tzpp" look almost identical at first glance.
Could we increase the hamming distance somehow?

regards,
dan carpenter