Re: [PATCH] sched/fair: Simplify some logic in update_sd_pick_busiest()

From: Valentin Schneider
Date: Fri Feb 02 2024 - 12:01:37 EST


On 02/02/24 01:02, David Vernet wrote:
> When comparing the current struct sched_group with the yet-busiest
> domain in update_sd_pick_busiest(), if the two groups have the same
> group type, we're currently doing a bit of unnecessary work for any
> group >= group_misfit_task. We're comparing the two groups, and then
> returning only if false (the group in question is not the busiest).
> Othewise, we break, do an extra unnecessary conditional check that's
> vacuously false for any group type > group_fully_busy, and then always
> return true.
>
> Let's just return directly in the switch statement instead. This doesn't
> change the size of vmlinux with llvm 17 (not surprising given that all
> of this is inlined in load_balance()), but it does shrink load_balance()
> by 88 bytes on x86. Given that it also improves readability, this seems
> worth doing.
>
> As a bonus, remove an unnecessary goto in update_sd_lb_stats().
>

Given that's a different scope than what the rest of the patch touches, I'd
rather see this as a separate patch.

Other than that:
Reviewed-by: Valentin Schneider <vschneid@xxxxxxxxxx>