Re: [PATCH 2/2] kasan: Rename test_kasan_module_init to kasan_test_module_init

From: Marco Elver
Date: Mon Feb 05 2024 - 07:37:43 EST


On Mon, 5 Feb 2024 at 07:09, Tiezhu Yang <yangtiezhu@xxxxxxxxxxx> wrote:
>
> After commit f7e01ab828fd ("kasan: move tests to mm/kasan/"),
> the test module file is renamed from lib/test_kasan_module.c
> to mm/kasan/kasan_test_module.c, in order to keep consistent,
> rename test_kasan_module_init to kasan_test_module_init.
>
> Signed-off-by: Tiezhu Yang <yangtiezhu@xxxxxxxxxxx>

Seems reasonable:

Acked-by: Marco Elver <elver@xxxxxxxxxx>

> ---
> mm/kasan/kasan_test_module.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/mm/kasan/kasan_test_module.c b/mm/kasan/kasan_test_module.c
> index 8b7b3ea2c74e..27ec22767e42 100644
> --- a/mm/kasan/kasan_test_module.c
> +++ b/mm/kasan/kasan_test_module.c
> @@ -62,7 +62,7 @@ static noinline void __init copy_user_test(void)
> kfree(kmem);
> }
>
> -static int __init test_kasan_module_init(void)
> +static int __init kasan_test_module_init(void)
> {
> /*
> * Temporarily enable multi-shot mode. Otherwise, KASAN would only
> @@ -77,5 +77,5 @@ static int __init test_kasan_module_init(void)
> return -EAGAIN;
> }
>
> -module_init(test_kasan_module_init);
> +module_init(kasan_test_module_init);
> MODULE_LICENSE("GPL");
> --
> 2.42.0
>
> --
> You received this message because you are subscribed to the Google Groups "kasan-dev" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to kasan-dev+unsubscribe@xxxxxxxxxxxxxxxx.
> To view this discussion on the web visit https://groups.google.com/d/msgid/kasan-dev/20240205060925.15594-3-yangtiezhu%40loongson.cn.