Re: [tip: x86/fred] x86/ptrace: Cleanup the definition of the pt_regs structure

From: Xin Li
Date: Tue Feb 06 2024 - 14:06:00 EST


On 2/3/2024 3:52 PM, H. Peter Anvin wrote:
On January 31, 2024 1:14:52 PM PST, tip-bot2 for Xin Li <tip-bot2@xxxxxxxxxxxxx> wrote:
The following commit has been merged into the x86/fred branch of tip:

Commit-ID: ee63291aa8287cb7ded767d340155fe8681fc075
Gitweb: https://git.kernel.org/tip/ee63291aa8287cb7ded767d340155fe8681fc075
Author: Xin Li <xin3.li@xxxxxxxxx>
AuthorDate: Tue, 05 Dec 2023 02:50:02 -08:00
Committer: Borislav Petkov (AMD) <bp@xxxxxxxxx>
CommitterDate: Wed, 31 Jan 2024 22:01:13 +01:00

x86/ptrace: Cleanup the definition of the pt_regs structure

struct pt_regs is hard to read because the member or section related
comments are not aligned with the members.

The 'cs' and 'ss' members of pt_regs are type of 'unsigned long' while
in reality they are only 16-bit wide. This works so far as the
remaining space is unused, but FRED will use the remaining bits for
other purposes.

To prepare for FRED:

- Cleanup the formatting
- Convert 'cs' and 'ss' to u16 and embed them into an union
with a u64
- Fixup the related printk() format strings

Suggested-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
Originally-by: H. Peter Anvin (Intel) <hpa@xxxxxxxxx>
Signed-off-by: Xin Li <xin3.li@xxxxxxxxx>
Signed-off-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
Signed-off-by: Borislav Petkov (AMD) <bp@xxxxxxxxx>
Tested-by: Shan Kang <shan.kang@xxxxxxxxx>
Link: https://lore.kernel.org/r/20231205105030.8698-14-xin3.li@xxxxxxxxx

[...]

diff --git a/arch/x86/kernel/process_64.c b/arch/x86/kernel/process_64.c
index 33b2687..0f78b58 100644
--- a/arch/x86/kernel/process_64.c
+++ b/arch/x86/kernel/process_64.c
@@ -117,7 +117,7 @@ void __show_regs(struct pt_regs *regs, enum show_regs_mode mode,

printk("%sFS: %016lx(%04x) GS:%016lx(%04x) knlGS:%016lx\n",
log_lvl, fs, fsindex, gs, gsindex, shadowgs);
- printk("%sCS: %04lx DS: %04x ES: %04x CR0: %016lx\n",
+ printk("%sCS: %04x DS: %04x ES: %04x CR0: %016lx\n",
log_lvl, regs->cs, ds, es, cr0);
printk("%sCR2: %016lx CR3: %016lx CR4: %016lx\n",
log_lvl, cr2, cr3, cr4);

Incidentally, the comment about callee-saved registers is long since both obsolete and is now outright wrong.

The next version of gcc (14 I think) will have an attribute to turn off saving registers which we can use for top-level C functions.


Forgive my ignorance, do we have an official definition for "top-level C functions"?

Thanks!
Xin