[PATCH 0/2 v2] Add cond_guard() to conditional guards

From: Fabio M. De Francesco
Date: Mon Feb 05 2024 - 09:26:38 EST


Add cond_guard() macro to conditional guards and use it to replace an
open-coded up_read() in show_targetN() and remove a block marked by an
'out' label.

Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
Cc: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>
Suggested-by: Dan Williams <dan.j.williams@xxxxxxxxx>
Suggested-by: Ira Weiny <ira.weiny@xxxxxxxxx>
Signed-off-by: Fabio M. De Francesco <fabio.maria.de.francesco@xxxxxxxxxxxxxxx>
---

Changes from RFC v4:
Changed the interface of cond_guard() to take a variable to store
a return code, the succes code and failure code, to enable a
later check of the returned code in that variable.
Changes from RFC v5:
Changed the interface of cond_guard() to take one or more statements
in its second argument to conform to Dan's final suggestion
(thanks).
Changes from v1:
Fixed a grammar error in the commit message of 1/2; replaced the
name of the second argument of cond_guard() with '_fail'
according to Jonathan's comments (thanks).

Fabio M. De Francesco (2):
cleanup: Add cond_guard() to conditional guards
cxl/region: Use cond_guard() in show_targetN()

drivers/cxl/core/region.c | 16 ++++------------
include/linux/cleanup.h | 14 ++++++++++++++
2 files changed, 18 insertions(+), 12 deletions(-)

--
2.43.0